OpenSSL升级后导致libcrypt.so.10和libssl.so.10找不到的解决

/ 0评 / 0

起因

机器因为安全需要,对OpenSSL进行了升级,通过openssl version可以查看版本为1.1,执行curl提示libcrypto.so.10库不匹配。

分析

OpenSSL是Linux的基础库,升级会带来不少问题,比如:weg, curl提示找不到libcrypt.so.10和libssl.so.10库

通过资料分析:

这个问题就是因为升级OpenSSL导致的,新版本的SSL把1.1版本的库替换了老的1.0库,导致老的程序不兼容。因此需要让老程序也可以继续工作,不至于全部升级一遍。

解决办法:

从本机或者其他机器上找到libcrypt.so.1.0和libssl.so.1.0文件,复制到问题机器的/lib64目录,在创建1.0版本的符号链接。

通过ldd /usr/bin/curl 可以看到程序链接的位置,在通过符号链接来解决。

发表评论

您的电子邮箱地址不会被公开。 必填项已用*标注